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How to Set Up Windows XP / Vista for Web Development with PHP and MySQL.

This tutorial is the first in a series about PHP and Web Development. To get started
we are going to set up a PC as a development workstation. For our purposes we
need to install a web server (Apache) - so that we can serve PHP files to our local
machine, PHP - a popular server side language, and MySQL - a popular and
powerful database server for creating databases.

There are many ways to install a web server, PHP, and MySQL on a Windows
platform. For ease we are going to use XAMPP.

XAMPP is a free download and is available for various platforms. XAMPP will install
Apache, MySQL, PHP and Perl on your computer. It will also install a few other tools
that will be useful for web development. XAMPP should not be used to serve your
website on the web because it has security limitations; however it’s ideal for local
development and testing.

There are two versions of XAMPP available to Windows users. A self extracting
installer, and a zipped version. We will be using the zipped version but the same
results can be achieved with the self extracting installer.

Installing XAMPP
1. Download XAMPP 1.7.2 zipped version for Windows from the XAMPP

website:
http://www.apachefriends.org/en/xampp-windows.html

2. Extract the files to C:\
Note: The zipped file contains a folder called ‘xampp’, so once extracted your
XAMPP installation will be located in: C:\xampp

3. Runthe setup_xampp file located here C:\xampp\setup_xampp.bat

4. Accept the default settings presented in the DOS window
Should | add shortcuts to the startmenu/desktop? (y/n) y

Should | locate the XAMPP paths correctly? (y/x = exit setup) y
Should | make a portable XAMPP without drive letters? (y/n) n

Continues on next page ....
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5. You will be notified “*XAMPP relocating...” Once the relocation routine has
run, your installation screen will look something like this:

¢ C:\WINDOWS\system32\cmd. exe

BEAUBHHUBBAERBBARBBHRBBHABBHABBHARBHBBRBREBBRERBRBRBBBRUBBBUB BB RBERERHY
# XAMPP 1.7.2 Setup t
"

# Copyright 2889 Carsten Wiedmann (FreeBSD License?
8

i
i
#
# Authors: Carsten Wiedmann <carsten_sttgtlgmx.de’ b3
big Kay Unge lgesang <kvoPFapachefriendsz.org> #
AHRRRABBRRRARAABREBRRRRRRR AR AR RARARRHBBRARRARRRRRBRRRRRRARHRBBRRRRBRBRRRBRS

Should | make a portable XAMPP without drive letters?

NOTE: You should use drive letters. if you want use services.
With USB sticks you must not use drive letters.

Your choice? (y/n>: n

relocating XAMPP. ..
XAMPP base package

re locate
relocate
pthHHdmln
Sendmail
reloc
reloca “AM opage
1rlnr1rxng AAMPP successful.

RAMPP is ready to use.

Press <Return’> to continue:

6. As advised ‘Press (Return) to continue’

7. You will be informed ‘I have set the timezone in ‘php.ini’ and ‘my.ini’ to
“Europe/London’ If you live outside the UK you may want to configure your
php.ini and my.ini files for your country. — More on php.ini and my.ini later

8. ‘Press (Return) to continue’ — You will be presented with a menu.

HERRRBHBRRRURREBUBEBERBBHBRBHBRERERERERERRBRRRRRURRBUERRBUBRBHBRBRBRBRBRRRSRYY
# ARHPP 1 2.2 - ‘vtup 1}

# Cop lLth 2889
- Sy BT
# Authors: Carsten W
Kay Vogelgesang (PUUUddethlLLHd,.UI'a

]
HURRBHHREREEERR R RN RNy

start XAMPP Control Panel
relocate XAMPP
‘:u)x-nt path: C:\xampp)
ahbhle HTYP° "
:

1?01 nnl; Ccurrent Pud/6 Cautod)
g mod_perl

9. Choose X’ from the menu to exit — Your installation of XAMPP is done!
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A quick look at XAMPP

Now that XAMPP is installed you may want to see what it looks like. Before you do, it
is worth noting that the XAMPP website has a great FAQ’s page should you
encounter any problems:

http://www.apachefriends.org/en/fag-xampp-windows.html

If you followed the ‘Installing XAMPP’ guide above you should have a links to the
XAMPP Control Panel in your ‘Start’ menu (All Programs—>XAMPP for Windows—>
XAMPP Control Panel) and on your desktop.

XAMPP Control
. . Panel
Launch XAMPP by clicking the ‘XAMPP Control Panel’ icon...

83 XAMPP Control Panel Application

H XAMPP Control Panel f Shell |
| [ setup |

Modules | Port-Check |
[Jsve Apache
[Jsve MySql
[Jsve FileZilla
[Jsve  Mercury

{Apache Friends Edition)

Tomcat

XAMPP Control Panel Version Z2.5.8 (Z002-07-28)
XAMPP for Windows Version 1.7.2

Windows 5.1 Build 2600 Platform Z Service Pack 3
Current Directory: C:\xampp

Status Check 0K

Above: XAMPP Control Panel
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The control panel consists of three distinct areas:
1. The “Modules” list — A set of modules that can be used. To start a module
click ‘Start’ button to the right of the module. To run a module as a service
check the appropriate box to the left of the module and click the ‘Start’ button.

2. The “Tools” panel — A set of buttons for quick access to XAMPP tools and
windows shortcuts.

3. The message area — This gives an overview of the XAMPP system, and
provides status messages for the modules running.
Check that Apache, PHP, and MySQL are functioning

1. From the XAMPP Control Panel click the ‘Start’ button to the right of the
‘Apache’ module. If successful the module will be listed as ‘Running’::

Modules

[Isve Apache Running ( Stop ) £ admin {

2. Click the ‘Start’ button to the right of the MySql module.

3. Click the ‘Admin’ button for the ‘Apache’ service. This should open a new
browser window with the URL: http://localhost/xampp/splash.php

4. Choose your language from the “Splash” screen.

5. You will get a congratulations message advising that XAMPP is installed —
You have just proved that Apache is working!

ortuguds / Portugudy (Breadl) / DDD

XAMPP 1.7.2}

Congratelations:
You have successhelly installed XAMPE on this systess

How you can start uzing 2pache and Co, You should frst try cStatuss on the left navigation to make sure sverything works fine.
For OpenGEl supert plRase wse e tast cartificate wih Des 22 0.0.1 or betes Jdocabest
#nvd very mportant! Big thanks for balp and =upport to Nemess, Kris, Bopey, PeOummy and ol cthar frisceds of XoMPR!

dood hk, Kay VoQeigesan + Kal 'Oswaks Seidar + Carstan Wisdmarn

Continues on following page...
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6. From the left hand menu of the above screen click ‘phpinfo()’ . If PHP is
working you will be show the phpinfo() page — It displays various PHP
settings and installed extensions.

This will prove that PHP is functioning.

System Windows NT HOME-OBDYSATHFX 5.1 build 2600 (Windows XP Professional
Service Pack 3) 1586 -

|Bulld Date Jul 22009 21:0253

| Compiler MSVCE (Visual C++ B.0)

Architecture *86

|Configure Command cscriptinologo configure js

| PR T N

7. Run the Security check from the left hand menu. A new window will open with
the results of an XAMPP security check.

Subject Status

These XAMPP pages are accessible through the network by anyone
Euary NAMPR damo page you ara looking at sight now is accessible by svaryone ovar the natvork. Everyons vho knows your

IP addrass can 1as these pages

The MySQL admin user root has NO password
Every local user on this Windows machine can access your MySQL datsbaxe vith sdministrator rights. You should set &

passvord

PhpMyAdmin is freely accessible by network
ShpMyAdrnin is sccassibla by netvork without & password, The configurstion 'httpd' or ‘cookie' in the “config.inc.php” can

help

The FileZilla FTP password was changed SECURE

4 POP3 server like Mercury Mail is not running or is blocked by a firewall! [UNKS

The Tomcat add-on is not installalied. UNKNOWN
_—_—_y

The insecure items are red, the secure ones are green, and the ones that
XAMPP can’t interrogate (usually because they are not running) are coloured
yellow.. There is a link to the security console to resolve these.

The Tormncat add-on Is not installalied.

Thea green marked points are secure; the red marked points are definitively unsecure and the yellow marked points couldn't be
checked (for example because the sofware to check isn't running).

To fix the problems for mysql, phpmyadmin and the xampp directory simply use
=5 hitp: /{localhost/security {xamppsecurity.php <= [allowed only for localhost]
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8. Click the security console link — the security console MySQL and XAMPP
directory screen will be displayed.

MYSQL SECTION: "ROOT"™ PASSWORD

MySQL Superlser: root

New password:

Rapeat the new password:

phpMyAdmin authentication:  htte O cookie &

Set a random password for the

S 'R
phpMyadmin user ‘pma'; Yes © Mo O

(File: C:\xampp\securty\mysqlrootpasswd txt)

|  Pesswordchenging |

XAMPP DIRECTORY PROTECTION (.htaccess)

User:
Password:

i

(F»!é: Cihxampp\sacurty\xamppdirpasswd.txt)

|  Securethe XAMPP directory |

9. Enter and confirm a password for the MySQL user ‘root’. From now on you
will need this password to log into MySQL and phpMyAdmin as user ‘root’.

10. Enter a username and a password for XAMPP directory — from now on you
will need this username and password to log into the XAMPP control panel.

11. Now that a MySQL root password has been set we can test MySQL. Stop the
MySQL module from running via the XAMPP control panel then restart it.
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Configure php.ini

The php.ini file is used for setting various parameters for PHP. After modifying the
php.ini file it's a good idea to restart Apache. With our development environment we
are going to configure PHP to work with XDebug — It's a debugging module that will
make it easier to locate any errors in PHP code.

Lines that are used for comments in the php.ini file start with a semi-colon ;”. A
commented line will not be loaded as part of the PHP configuration. The php.ini file
has number of commented lines.

We will also configure PHP so that it integrates with Eclipse - our IDE (Integrated
Development Environment).

1. Locate the ‘php.ini’ file here: C:\xampp\php\php.ini
2. Open the file in a text editor (notepad will do)

3. Use the “find” function of your text editor to find the line that sets
“implicit_flush”; if it is set to “Off” change the value to “On”
eg. implicit_flush = On

NOTE: setting this can degrade the performance of PHP, but it is useful for
debugging.

4. Find the line that sets “report_zend_debug” by default this is commented with
a semi-colon. Uncomment this line by removing the semi-colon.
eg. report_zend_debug =0

5. Find and uncomment the line:
zend_extension = "XAMPP_HOME\php\ext\php_xdebug.dll".

6. Find the configuration block “[XDebug]” and make the following changes:

e Find and uncomment the line:
xdebug.remote_host=localhost
Change the value of the setting from localhost to 127.0.0.1

e Find and uncomment the line:
xdebug.remote_enable =0
Change O to 1.

e Find and uncomment the line:
xdebug.remote_handler = "dbgp"

e Find and uncomment the line:
xdebug.remote_port = 9000

7. Save the php.ini file and close.
8. From the XAMPP control panel restart Apache

That’s the php.ini file configured for our development environment. The next step is
to set up Eclipse.

PHP Web Development Tutorial Part 1 © Zoonder Limited 2009

Page 8



Zoonder

Installing and configuring Eclipse for PHP development.

Eclipse is an IDE or Integrated Development Environment. It can be used for
development in many different programming languages. There is a version available
that contains tools already packaged for PHP development. The version we are
going to use is Eclipse PDT (Eclipse PHP Development Tools). Let’s get started...

Eclipse is an application written in Java. Before you can use Eclipse you will need to
download the latest version of java from Sun Microsystems:
http://www.java.com/en

Install Eclipse PDT

1. Download Eclipse PDT - PHP development Tools
http://www.eclipse.org/pdt/downloads/

2. Extract the files to C:\
A folder called ‘eclipse’ will be created

3. For your convenience create a short cut to Eclipse and place it on your
desktop. The program file for Eclipse can be found in C:\eclipse.

JB
% eclipse

4. Run Eclipse and set the workspace directory to
C:\xampp\htdocs\workspace

& Workspace Launcher @
Select a workspace

Eclpse stores your projects in a Folder caled a workspace.
Chooss & workspace Folder to use For this session.

yotkspaca: Ciixamppihtdocs\warkspace v (‘-me_“

[Juse this as the defaut and do not ask again

[ o | cencel |

You can call this directory anything you like. In this example we've used
‘workspace’. This is where all your development projects will be created.

PHP Web Development Tutorial Part 1 © Zoonder Limited 2009

Page 9


http://www.java.com/en
http://www.eclipse.org/pdt/downloads/

Zoonder

5. The Eclipse workbench will load with a welcome screen

Weizeme 10 EcSper far PP Do vwiopeny

®

6. Close the welcome Screen, and you will be presented with the default Eclipse

layout/workbench for PHP development.

B L e Relate peapds Tegdh Besd b g e
PO Q Ny v
RARRME S T |

N &ne
o ’
A ouiew n ot eodtee

We have successfully installed Eclipse PDT on Windows XP.
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Now that Eclipse is installed we need to configure it to work with XDebug.

1. From the Eclipse Window menu choose Preferences

Window B35
Naw Window

Open Perspective »
Show Yiew

Customize Perspective...
Save Perspective As...
Reset Perspective, .,
Cose Perspective

Close All Perspectives

Navigation »

‘Web Browser »

Prefarencas

2. A new window will open. Using the navigation on the left choose
PHP->Debug. In the default settings area change the PHP debugger to

XDebug.

~p

references

Germv ol ~

Dynamic Languages

Heb

IrataliUpdare Def st Settiengs

Java

o PP Debgger: XDetug

Acpeyance

R

Iret sted Debugoe
Step Flterryg
Warkbench Optior
» Edtor
News Frogect Layout
P Exsoutables
PP Inderpreter
PP Lbrares
P Maouy
P Servers
Rencee Systems
funDetug
| Server
Taths
Team
Usage Datas Colector
Yahaabon ¥
< >

?)

Ercodng Settings

[ Brmak ot Fest Lee

E I I

Server: Cof ot P19 Web Server

v PP Exeotable:  More Defyod

Detog Trarsler Encodng | UTF-0
Debug Qutpt Encoding | LIRS

(Restor Qofos | [ dpohy |

o || cancel

3. Click ‘Configure’ to the right of the option you just changed. This will bring up

a list of installed debuggers.
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Check that XDebug is using port 9000 — This is the setting used in our php.ini
file.

You may get a warning advising that the port is already in use. If this is the
case change the port to say 10001 apply the change, and then edit your
php.ini file so that xdebug.remote_port = 10001
Apply the setting.

4. From the navigation choose PHP->Debug->Workbench Options

5. Select ‘Always’ for ‘Switch back to the PHP perspective when debugging has
terminated’

& Preferences

+
+
+
*
*

Workbench Options o v

General
| Dynamic Languages Alow multiple debug sessons
Heb O hways O Never () Prompt
i InstaliUpdate
Java Swstch back to the PHP perspective when debuggng has terminated
- PHP @ always O never (O Prompt

Appearance

& Code Style Workbench Options
= Debug [“] Open in Browser
Installed Debuggers [¥] Opan PHP Dabrug Views (Debug Output, Browsar Output)
Step Fitenng
Workbench Options
+ Edtor

New Project Layout

PHP Executables

PHP Interprater

PHP Lbraries

PHP Manual

PHP Sarvers
+ Remote Systems
# RunjDebug
H Server
4+ Tasks
# Team
+ Usaga Data Collactor

validation

+ ‘Web
+ ‘Web Services
#H XML

[Rsstc«‘e Qefwts][ Apply ]

9 ok J[ concel |

Continues on next page....
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6. Next we need to change the servers in the ‘preferences window’. Navigate to

PHP->PHP Servers

& Preferences

i General
4 Dynamic Languages
it Hebp
Instal{Update
i Java
(= PHP
Appearance
* Code Style
+ Debug
* Edtor
Mew Project Layout
PHP Executables
PHP Interpreter
PHP Lbraries
PHP Manual
PH Servers.
i+ Remote Systems
% RuniDebug
i Server
+ Tasks
it Team
¥ Usage Data Collechor
Yaldation
# ‘Web
it ‘Web Services
i AML

&

I )
{ \2/,

PHP Servers P -

PHP Servers Management

Note that removing a server definition will also remove anry launch configur ation that is

ushg ik,

e o
[ex )

| Default PHP Web Serve... http:/ localhost

[ OK ][ Cancel J

7. Select the default PHP Web Server and click ‘Edit’.

Continues on next page....
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8. Enter the path of the document root —we set this as workspace

http://localhost/workspace/

E Edit Server

Edit Server [Default PHP Web Server]

Specify the Server Information

S Path Mappingﬂ‘f

Mame: [ Default PHP Web Server

Enter the URL that points to the document root of this server

iLhttp:,f,flo_cg@ostngﬁspace,fl

@ Cancel

9. Click ‘OK’ to confirm

Congratulations you have successfully set up a Windows based PHP web
development environment.

To get started we are going to set up a really simple test project to introduce the
basics so that we can focus on development later in the tutorials.

Continues on next page ...
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Using Eclipse

Eclipse is a powerful IDE used for lots of different programming languages. The
Eclipse PDT (Eclipse PHP Development Tools) build is ideal for PHP development.
To become familiar with eclipse it's necessary to know some of the terminology used.

Eclipse Terminology

Workbench — The workbench is the main Eclipse window. The workbench allows
you to focus on a task or job. In Eclipse terms this is known as a ‘perspective’.

Perspective - A ‘Perspective’ is a defined or customised workbench layout that will
facilitate the tasks or job that you are doing. Eclipse PDT has two packaged layouts:

1. PHP —for editing and working with PHP files
2. PHP Debug - for debugging PHP

Perspectives can be opened from the menu by selecting Window->Open
Perspective. The default one should be the PHP perspective.

Project — This is the project you are working on. A project is really just a folder or
directory to contain your files; it helps you to keep your work organised logically.
Within a project you can have as many folders and files that relate to your project as
you like.

By Way of example we shall create a tiny project to test our configuration.
Creating a Project

From the File menu select New>PHP Project

Enter ‘FirstProject’ as the project name

Click ‘Finish’

In the Project Explorer part of the PHP perspective you will have a project. It
will contain two paths/resources — One to the project work space and one to
the PHP libraries.

& PHP - Eclipse

File Edit Source Refactor Mavigate Search

=<y Yo = 0 v 5 T
e ; ﬁ v . =

E PHPExpl 23 Tg TypeHie T O

e NS

== FirstProject

R PHP Include Path

i+ ¥, PHP Language Library

You have created a new ‘Project’ Next you want to add a file.
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Adding a File to your Project

Now that you’ve created a Project you will want to add files. We are going to add one
file and then open it in a web browser.

1. From the File Menu choose New=>PHP File

2. A‘New PHP File’ window will open.

& New PHP File

New PHP file
€3 Folder must be pecifind

i -

Source Foldar Browss

Fie Nome newfie.php

@ Yy i

3. Browse for a source folder and choose ‘FirstProject’
4. The default filename is ‘newfile.php’. Change this to ‘test.php’.

5. Click ‘Finish’

Continues on next page....
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6. You will notice that a new file has been created under your project, and your
new file has been opened for editing.

& PHP - FirstProject/test.php - Eclipse

File Edit Source Refactor MNavigate Search Project Run  Windo

MU S O o ® S 4

H pHeExpl 22 T8 Typerie | = 01|/ [6) testiphp 53
~

5% Y| 1 <?php
= =5 FirstProject . 2

& [8) test.php
-2 PHP Include Path
+ B, PHP Language Library

7. Add the following line of PHP code to your file:
phpinfo () ;

8. Close the PHP script by adding the following line
2>

9. Your code window should look like this

7] *test,php XN

1 <?php
phpinfo():

i

S

LSRR A

23]

Note: The asterisk (*) next to the file name indicates that the file has not been
saved since it was edited.

10. From the file menu select ‘Save’ or click the save icon I-l—ll on the workbench
11. Ensure that XAMPP is running and that Apache and MySQL are running.

12. Launch your favourite browser.
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13. Enter the following URL into the address bar
http://localhost/workspace/FirstProject/test.php
As you can see the URL shows our Server localhost, the ‘workspace’ folder

that we created for storing our projects, the project folder ‘FirstProject’ and
the file we have just created called ‘test.php’.

14. You should see the PHP Info page in your browser window.

System Windows NT HOME-OBDYBQTHFX 5.1 build 2600 (Windows XP Professional
Service Pack 3) i586

| Build Date Jul 2 2009 21:02:53

Compiler MEVCE (Visual C++ 6.0)

Architecture XB6

Configure Command cscript inologo configure js

Server AP Apache 2.0 Handier

Virtual Directory Support | enabled

Configuration File (php.ni) | 7o vaiue

|Path
|Loaded Configuration File | Cxampplahplphp.ini

lﬂ..-.l.l. Miv Cas ELT Y

This tutorial has shown:

How to install and configure XAMPP

How to edit the ‘php.ini’ file

How to set up Eclipse PDT for PHP Web Development
The basics of the Eclipse workbench

How to create a new PHP Project with Eclipse

How to create a new PHP File with Eclipse

How to open your PHP files in a browser on your computer.
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